dools 0.0.10

dools #

Build Status Pub Package

Development tools installer from command line.

Supported tools: #

Installation #

Requirements: dart-sdk

> pub global activate dools

To update, run activate again.

Usage #

Display usage:

> dools

Changelog #

0.0.10 #

  • Captured non-connection errors.
  • Fixed node.js version check.

0.0.9 #

  • Fixed node.js version check.

0.0.8 #

  • Added confirmation before install.
  • Added version info flag.
  • Added M2_HOME environment variable for maven installation.
  • Added node.js installer (only Windows OS).

0.0.6 #

  • Fixed issue when installation path didn't exists.
  • Improved text in downloading.

0.0.5 #

  • Fixed issues.

0.0.4 #

  • Initial version, install maven & gradle.

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate dools

2. Use it

The package has the following executables:


$ dools

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dools: ^0.0.10

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dools/commands/builder.dart';
import 'package:dools/commands/install.dart';
import 'package:dools/commands/tools/gradle.dart';
import 'package:dools/commands/tools/maven.dart';
import 'package:dools/commands/tools/nodejs.dart';
import 'package:dools/error.dart';
import 'package:dools/text.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0