Development tools installer from command line.
> pub global activate dools
To update, run activate again.
You can install the package from the command line:
$ pub global activate dools
The package has the following executables:
Add this to your package's pubspec.yaml file:
dependencies: dools: ^0.0.10
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
import 'package:dools/commands/builder.dart'; import 'package:dools/commands/install.dart'; import 'package:dools/commands/tools/gradle.dart'; import 'package:dools/commands/tools/maven.dart'; import 'package:dools/commands/tools/nodejs.dart'; import 'package:dools/error.dart'; import 'package:dools/text.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.20.1 <2.0.0|