domino_bulma 0.4.4

domino_bulma #

Domino components using the Bulma CSS framework.

This package is experimental and API may change. Contributions are welcome!

Changelog #

0.4.4 #

  • Extra lints and Dart 2.2 code.

0.4.2 #

  • Enabled Dart2.

0.4.0 #

  • Upgrade to domino 0.4.0

0.3.4-dev #

  • Support … inside pagination.

0.3.3 #

  • Implement component: modal, pagination, tabs.
  • Implement element: image.
  • Text color and image dimension modifiers.

0.3.2 #

  • Fix clazz methods.
  • Fix input class on input().
  • Implement form elements: select, option, checkbox, radio, textarea.
  • Implement elements: tag, title.

0.3.1 #

Breaking Changes:

  • FormField and Input are no longer Components, rather they became build methods.

0.3.0 #

Breaking Changes:

  • Updated to domino 0.3.0.
  • Removed Mods, using Modifier instead which exposes Setters.

0.2.0 #

Breaking Changes:

  • Removed BulmaComponent, clients should use Mods to add arbitrary bulma classes.
  • Removed most Component classes, using methods instead in simple cases.
  • Simplified parameters (removed is prefix).
  • Removed *Mod enums, using String class values instead.

New features:

  • Implemented column options.
  • Implemented layouts: level, media, hero, section, and footer.
  • Implemented elements: notification, and progress.
  • Implemented components: breadcrumb, partial card, message.

0.1.0 #

  • Input.value to provide the current value in the <input> field.
  • Upgraded to domino 0.2.0, with breaking changes: content is used instead of text or children.

0.0.1 #

  • Initial version.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  domino_bulma: ^0.4.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:domino_bulma/domino_bulma.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
78
Overall:
Weighted score of the above. [more]
45
Learn more about scoring.

We analyzed this package on Jul 10, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:domino_bulma/domino_bulma.dart.

Health issues and suggestions

Document public APIs. (-1 points)

107 out of 107 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

The package description is too short. (-12 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and domino_bulma.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
domino ^0.4.2 0.4.5
Transitive dependencies
async_tracker 0.1.1
Dev dependencies
pedantic ^1.0.0

Admin