dobx lib for protostuffdb #
Generate code (optional, generated code is checked in) #
mkdir -p target wget -O target/fbsgen-ds.jar https://repo1.maven.org/maven2/com/dyuproject/fbsgen/ds/fbsgen-ds-fatjar/1.0.1/fbsgen-ds-fatjar-1.0.1.jar git clone https://gitlab.com/dyu/ds-proto.git p ./codegen.sh
Install deps #
- Fix 'subtype' errors for collection addAll/insertAll when used with
- Fix http dependency
- Add Store.page_info method
- Fix append/prepend bug
- Fix update/reload diff
- Updated flutter (2017-04-04) and fixed broken imports caused by the update.
- Added MultiCAS methods for update ops.
- Added store with fetch and update with pubsub on loading/desc state.
- json rpc over http
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: dobx_ds: ^0.5.1
2. Install it
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
import 'package:dobx_ds/ds.dart'; import 'package:dobx_ds/ds/prk/p1.dart'; import 'package:dobx_ds/ds/prk/p4.dart'; import 'package:dobx_ds/ds/prk/p8.dart'; import 'package:dobx_ds/ds/prk/pd.dart'; import 'package:dobx_ds/ds/prk/pk.dart'; import 'package:dobx_ds/ds/prk/ps.dart'; import 'package:dobx_ds/mc.dart'; import 'package:dobx_ds/observables.dart'; import 'package:dobx_ds/observables.g.dart'; import 'package:dobx_ds/rpc.dart'; import 'package:dobx_ds/store.dart'; import 'package:dobx_ds/types.dart'; import 'package:dobx_ds/util.dart'; import 'package:dobx_ds/validation.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Analysis issues and suggestions
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
Maintenance issues and suggestions
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.22.0 <2.0.0|