dio_mock_interceptor 2.1.0 copy "dio_mock_interceptor: ^2.1.0" to clipboard
dio_mock_interceptor: ^2.1.0 copied to clipboard

This widget help you to mock backend responses in flutter project.

CHANGELOG #

2.1.0 - 2024.01.28 #

  • Extend req usage

2.0.0+1 - 2024.01.27 #

  • Refine examples and docs

2.0.0 - 2024.01.27 #

  • Code refactoring and use template_expressions library to support req、vars expressions

1.4.0 - 2024.01.24 #

  • Simply support variable

1.3.0 - 2024.01.01 #

  • Increase dart support version to 4.0.0

1.2.0 - 2024.01.01 #

  • Extend template usage
  • Simple EL, ex: ${req.data}、${template}、${templates}

1.1.0 - 2023.12.31 #

  • Mass data support

1.0.1 - 2023.6.18 #

  • Compatibility update for 6.0.0

1.0.0+1 - 2023.3.5 #

  • Add an example of usage.

1.0.0 - 2023.2.28 #

  • A mock interceptor for Dio 5.0.
6
likes
140
pub points
69%
popularity

Publisher

verified publisheryong-xin.tech

This widget help you to mock backend responses in flutter project.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dio, flutter, template_expressions

More

Packages that depend on dio_mock_interceptor