dialog_information_to_specific_platform 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • new53

dialog_information_to_specific_platform #

Este pacote refere-se à widgets especializados de AlertDialog e CupertinoAlertDialog. Você precisa apenas invocar o widget deste pacote e, de acordo à plataforma em que sua aplicação esteja sendo executada, será renderizado um Material Dialog ou Cupertino Dialog.

Getting Started #

Para a utilização deste pacote, antes de tudo, é preciso configurar o pubspec.yaml de acordo ao apresentado à seguir.

dependencies: dialog_information_to_specific_platform: <última-versão>

Após a configuração, é preciso executar flutter packages get, na console/terminal ou em seu IDE.

Em seu Widget é necessário importar os pacotes a seguir, onde o segundo será necessário apenas para a criação dos botões para a Dialog, mas é possível você enviar um List com seus Widgets.

import 'package:dialog_information_to_specific_platform/dialog_information_to_specific_platform.dart'; import 'package:dialog_information_to_specific_platform/flat_buttons/actions_flatbutton_to_alert_dialog.dart';

Uso básico #

Como teste para a visualização de uma dialog, teremos inicialmente a imagem a seguir, exibindo um Scaffold com um FAB que, ao acionado, exibirá a Dialog.

A visão do teste de referência com um FAB para exibir a dialog e a visão do teste de referência com a exibição do dialog

Para que possamos chegar as imagens anteriores, precisamos implementar o widget apresentado na sequência.

import 'package:dialog_information_to_specific_platform/dialog_information_to_specific_platform.dart'; import 'package:flutter/material.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget { @override Widget build(BuildContext context) { return MaterialApp( title: 'Platform Dialog Demo', theme: ThemeData( primarySwatch: Colors.blue, ), home: MyHomePage(title: 'Platform Dialog Tester'), ); } }

class MyHomePage extends StatefulWidget { MyHomePage({Key key, this.title}) : super(key: key);

final String title;

@override
_MyHomePageState createState() => _MyHomePageState();

}

class _MyHomePageState extends State

[0.0.1] - 12/02/2020 #

  • Liberação inicial para testes de publicação de e verificação do Markdown no README.md.

[0.0.2] - 19/02/2020 #

  • Ajustes no valor padrão para a propriedade isEnabled do ActionsFlatButtonToAlertDialog.
  • Primeira validação no Markdown do README.md para tradução para o inglês

example/README.md

example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dialog_information_to_specific_platform: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dialog_information_to_specific_platform/dialog_information_to_specific_platform.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
9
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
53
Learn more about scoring.

We analyzed this package on Feb 26, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.8

Health suggestions

Format lib/dialog_information_to_specific_platform.dart.

Run flutter format to format lib/dialog_information_to_specific_platform.dart.

Format lib/src/information_cupertino_alert_dialog.dart.

Run flutter format to format lib/src/information_cupertino_alert_dialog.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test