dht_dart 0.0.7
dht_dart: ^0.0.7 copied to clipboard

A DHT protocal implemented by Dart. This package implemented BEP-0005 for torrent client

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add dht_dart

With Flutter:

 $ flutter pub add dht_dart

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  dht_dart: ^0.0.7

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:dht_dart/dht_dart.dart';
0
likes
100
pub points
45%
popularity

A DHT protocal implemented by Dart. This package implemented BEP-0005 for torrent client

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

bencode_dart, dartorrent_common

More

Packages that depend on dht_dart