device_apps 1.0.9 icon indicating copy to clipboard operation
device_apps: ^1.0.9 copied to clipboard

outdated

Plugin to get the list of applications installed on the device (Android only)

[1.0.9] - 13th December 2019 #

  • Add path to APK file (PR #16)
  • Add install and update time fields (PR #18)
  • Add a missing break statement when opening the app
  • Fix warnings in the code

[1.0.8] - 29th May 2019 #

  • Fix issue #11 (>= Flutter 1.6)

[1.0.7] - 3rd April 2019 #

  • The version code is now available in the Dart code

[1.0.6] - 21th February 2019 #

  • For each application, you have now access to the "data directory" path (thanks to Ryan Gonzalez)

[1.0.5] - 21th January 2019 #

  • Some tests apps does not have a version_name. From now on, the plugin will just ignore them

[1.0.4] - 27th December 2018 #

  • Ability to filter only launchable apps (thanks to Damodar Lohani)

[1.0.3] - 17th December 2018 #

  • Some asserts added + a different class is used when an icon is passed

[1.0.2] - 15th December 2018 #

  • Support for the application icon (thanks to Damodar Lohani)
  • Fetching the applications list is now processed in a background thread in the Android code

[1.0.1] - 30th October 2018 #

  • New attribute to detect whether the app is user or system

[1.0.0] - 6th June 2018 #

  • Initial release (support for Android only)
189
likes
0
pub points
96%
popularity

Publisher

shield icon for verified publishersdaad.mobi

Plugin to get the list of applications installed on the device (Android only)

Repository (GitHub)
View/report issues

License

unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on device_apps