dev_test 0.15.3+1
dev_test: ^0.15.3+1 copied to clipboard

Brings (back) the solo and skip features on top of the test package

0.15.3+1 #

  • recursivePubPath now check whether dart version is supported
  • dart 2.14 lints

0.15.2+2 #

  • Add dry-run options to run_ci.

0.15.1 #

  • nnbd supports, breaking change.

0.13.5 #

  • Add build_support.dart to help building project for testing.
  • Allow running on NNBD projects

0.13.3+12 #

  • Add packageRunCi to run common dart/flutter package test, node test and nnbd tests.
  • Skipped dart pub run build_runner test -- -p chrome on travis for ioPackageRunCi
  • Add run_ci executable, usable with dart pub global run dev_test:run_ci

0.13.1+1 #

  • remove meta code allow code sharing with flutter

0.12.0 #

  • dart2 only

0.11.0 #

  • implicit-casts: false support

0.10.0 #

  • bug fix
  • dart 2.0.0 support

0.6.0 #

  • Add for multiple setUp(), tearDown(), setUpAll() and tearDownAll() in the same group
  • Travis test integration

0.5.0 #

  • Add support for setUpAll() and tearDownAll() methods

0.4.0 #

  • Initial revision with solo_test, solo_group, skip_test and skip_group support
0
likes
130
pub points
64%
popularity

Publisher

tekartik.com

Brings (back) the solo and skip features on top of the test package

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

args, collection, matcher, meta, path, pool, process_run, pub_semver, stack_trace, test, yaml

More

Packages that depend on dev_test