Dart wrapper for deelearnjs
Most code generated by js_facade_gen.
A more darty interface will eventually be written that does away with the need for things like
allowInterop for function arguments, replaces promises with futures and adheres to the dart style guide.
See examples for dart ports of the typescipt examples.
- Port more examples
- Write dart interface that encapsulates js interop requirements
- Initial version, created by Stagehand
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: deeplearnjs_facade: ^0.0.1
2. Install it
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Analysis issues and suggestions
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
Maintenance issues and suggestions
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.20.1 <2.0.0|