deep_map 1.0.0+1

Flutter Android iOS web

getDeep and setDeep for dart maps

Deep Map #

lesnitsky.dev GitHub stars Twitter Follow

Installation #

dependencies:
  deep_map: ^1.0.0

Example #

import 'package:deep_map/deep_map.dart';

final a = {};

a.setDeep('a.b.c', 42);

a.getDeep('a'); // { b: { c: 42 } }
a.getDeep('a.b.c'); // 42

License #

MIT

2
likes
80
pub points
0%
popularity

Publisher

lesnitsky.dev

getDeep and setDeep for dart maps

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on deep_map