de 1.0.3
de: ^1.0.3 copied to clipboard

Dart native js
Flutter Android iOS Linux macOS web Windows

Differential Evolution Optimization tool for Dart. The implementation supposes the objective function is a maximation and optimization parameters are customizable.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  de: ^1.0.3

2. Install it

You can install packages from the command line:

with pub:

$ dart pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:de/de.dart';
0
likes
80
pub points
0%
popularity

Differential Evolution Optimization tool for Dart. The implementation supposes the objective function is a maximation and optimization parameters are customizable.

Homepage

Documentation

API reference

Uploader

mhsatman@gmail.com

License

LGPL 3.0 (LICENSE)

Dependencies

pso

More

Packages that depend on de