dartwiki 1.0.0+2
dartwiki: ^1.0.0+2

Dart native js
Flutter Android iOS web

A simple to use wikipedia search tool and support multiple languages

A library that allow you to search and query wikipedia page


void changeLanguage() async {
  var wiki = Wikipedia();
  wiki.wikiLocation = WikiLocations.zh;
  var result = await wiki.search('你好世界');
  print(result);
}

void searchUseSteam() async {
  var wiki = Wikipedia();

  wiki.stream.listen((event) {
    print('Get event: $event');
  });
  await wiki.search('hello world');
  await wiki.search('hello world');
}

void queryPage() async {
  var wiki = Wikipedia();
  var results = await wiki.search('hello world');
  var queryResults = await wiki.getPage(results.searchResults[0].title);
  print(queryResults);
}
0
likes
100
pub points
21%
popularity

A simple to use wikipedia search tool and support multiple languages

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

sirily1997@gmail.com

License

BSD (LICENSE)

Dependencies

dio

More

Packages that depend on dartwiki