dartle 0.10.0
dartle: ^0.10.0 copied to clipboard

A simple build system written in Dart. Tasks are declared in a regular Dart file.

Use this package as an executable

1. Install it

You can install the package from the command line:

$ dart pub global activate dartle

Use it

The package has the following executables:

$ dartle

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add dartle

With Flutter:

 $ flutter pub add dartle

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  dartle: ^0.10.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:dartle/dartle.dart';
3
likes
120
pub points
3%
popularity

A simple build system written in Dart. Tasks are declared in a regular Dart file.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

actors, args, clock, collection, crypto, io, logging, meta, path, test_report_parser

More

Packages that depend on dartle