darternator 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 30

darternator #

A library for Dart developers.

Usage #

A simple usage example:

import 'package:darternator/darternator.dart';

main() {
    String str;
    if(strIsNullOrEmpty(str)) {
        print('It works!');

Features and bugs #

Please file feature requests and bugs at the issue tracker.

0.0.1 #

  • Initial version

0.0.2 #

  • Upgrade to Dart 2


import 'package:darternator/darternator.dart';

main() {
  String str;
  if(strIsNullOrEmpty(str)) {
    print('It works!');

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  darternator: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:darternator/darternator.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1

Health suggestions

Format lib/darternator.dart.

Run dartfmt to format lib/darternator.dart.

Maintenance suggestions

Package is getting outdated. (-87.95 points)

The package was last published 98 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
Dev dependencies
test >=1.0.0 <2.0.0