dartcash 1.1.1+1

  • Readme
  • Changelog
  • Installing
  • 64

Pure dart implementation of GNUCash sqlite format file support.

Offers read-only access to the contents of a file in the GNUCash sqlite format. The following operations are supported:

  • List of accounts including current balances in both the account commodity and base currency.
  • List details of splits and transactions belonging to an account.
  • Account summary functions for income/expense reports.

Acknowledgements:

1.0.0 #

  • Initial version, created by Stagehand

1.0.1 #

  • Add example and clean up all lint warnings

1.1.0 #

  • Add natural sign support and move stringification functions into commodity class.

1.1.1 #

  • Add accountSummary calculations functions.

1.1.1+1 #

  • Fix bug with calling book.close() on a null session.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dartcash: ^1.1.1+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dartcash/gnc_account.dart';
import 'package:dartcash/gnc_book.dart';
import 'package:dartcash/gnc_commodity.dart';
import 'package:dartcash/gnc_database.dart';
import 'package:dartcash/gnc_database.g.dart';
import 'package:dartcash/gnc_split.dart';
import 'package:dartcash/gnc_utils.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
32
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
64
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package does not support Flutter platform android

Because of import path [package:dartcash/gnc_account.dart, package:dartcash/gnc_commodity.dart, package:dartcash/gnc_database.dart, package:moor_ffi/moor_ffi.dart] that declares support for platforms:

Package does not support Flutter platform ios

Because of import path [package:dartcash/gnc_account.dart, package:dartcash/gnc_commodity.dart, package:dartcash/gnc_database.dart, package:moor_ffi/moor_ffi.dart] that declares support for platforms:

Package does not support Flutter platform linux

Because of import path [package:dartcash/gnc_account.dart, package:dartcash/gnc_commodity.dart, package:dartcash/gnc_database.dart, package:moor_ffi/moor_ffi.dart] that declares support for platforms:

Package does not support Flutter platform macos

Because of import path [package:dartcash/gnc_account.dart, package:dartcash/gnc_commodity.dart, package:dartcash/gnc_database.dart, package:moor_ffi/moor_ffi.dart] that declares support for platforms:

Package does not support Flutter platform web

Because of import path [package:dartcash/gnc_account.dart, package:dartcash/gnc_commodity.dart, package:dartcash/gnc_database.dart, package:moor_ffi/moor_ffi.dart] that declares support for platforms:

Package does not support Flutter platform windows

Because of import path [package:dartcash/gnc_account.dart, package:dartcash/gnc_commodity.dart, package:dartcash/gnc_database.dart, package:moor_ffi/moor_ffi.dart] that declares support for platforms:

Package not compatible with runtime web

Because of the import of dart:io via the import chain package:dartcash/gnc_account.dartpackage:dartcash/gnc_commodity.dartpackage:dartcash/gnc_database.dartdart:io

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (moor_ffi).

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and dartcash.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.8.1 <3.0.0
intl ^0.16.1 0.16.1
moor ^3.1.0 3.2.0
moor_ffi ^0.5.0 0.5.0 0.7.0
Transitive dependencies
charcode 1.1.3
collection 1.14.13
convert 2.1.1
ffi 0.1.3
meta 1.1.8
path 1.7.0
synchronized 2.2.0+1
typed_data 1.2.0
Dev dependencies
build_runner any
moor_generator any
pedantic ^1.9.0 1.9.0 1.9.1
test ^1.14.4