dartabase_core 1.0.2

  • Readme
  • Changelog
  • Installing
  • 42

Dartabase Core #

[visit http://dartabase-app.appspot.com](http://dartabase-app.appspot.com/)

shared lib used by Dartabase Tools (no need for you to do anything)


changelog 1.0.2 fixed some Dart > 2.0 issues changelog 1.0.1 changed Dart SDK now: '>=2.0.0-dev <3.0.0' changelog 1.0.0 changed Dart SDK to sdk: '>=2.0.0-dev.32.0 <2.0.0' changelog 0.6.1 added missing sqlite string on configLoad changelog 0.6.0 started adding sqlite support changelog 0.5.2
fixed issue with default value for Date/Time changelog 0.5.1 improved console output adapted database type recognition to enable BLOBs changelog 0.5.0 create backup of generated files if already exists and content changed added database types for creating dart files from extracting existing databases added variable relationDivider char_${relationDivider}_user eg char_2_user or char_t0_user changelog 0.4.1 now using pretty print to store json in files changelog 0.4.0 now working with _InternalLinkedHashMap instead of _LinkedHashMap

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  dartabase_core: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:dartabase_core/dartabase_core.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Mar 25, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Health suggestions

Fix lib/dartabase_core.dart. (-5.84 points)

Analysis of lib/dartabase_core.dart reported 12 hints, including:

line 1 col 9: Name libraries using lowercase_with_underscores.

line 5 col 68: Use lowercase_with_underscores when specifying a library prefix.

line 38 col 21: Unnecessary new keyword.

line 52 col 22: Unnecessary new keyword.

line 53 col 69: 'APPEND' is deprecated and shouldn't be used. Use append instead.

Maintenance suggestions

The package description is too short. (-18 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and dartabase_core.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev <3.0.0
dev_string_converter >=0.2.0 <1.0.0 0.3.0