A command line application to update the Dart SDK for Linux x64 systems.
pub global activate dart_updater
dart_updater, you must add 2 variables to your environment variables :
DART_SDK_PATH: Path where the Dart SDK will be installed.
You should also have a standalone Dart version somewhere on your system to run this package. But once you run it once, you can always keep your SDK up-to-date.
Example usage #
Showing help #
$ dart_updater --help
Showing help for specific command #
$ dart_updater upgrade --help
$ dart_updater upgrade -c dev/release
$ dart_updater upgrade -c stable/release
- Added switch to be able to install specific version of the SDK.
- Removed Dartium support
- Added dev compiler support
- Updated Dependencies
- Updated Readme/Changelog
- Added support for environment variables for dartium and dart-sdk
- Testing a viable version
- Initial version, created by Stagehand
Use this package as an executable
1. Install it
You can install the package from the command line:
$ pub global activate dart_updater
2. Use it
The package has the following executables:
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: dart_updater: ^0.4.0
2. Install it
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Analysis issues and suggestions
Fix dependencies in
pub upgrade failed with the following output:
ERR: The current Dart SDK version is 2.6.1. Because dart_updater depends on unscripted >=0.0.2 which requires SDK version <2.0.0, version solving failed.
Maintenance issues and suggestions
Fix platform conflicts. (-20 points)
Error(s) prevent platform classification:
Fix dependencies in
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
Package is too old. (-100 points)
The package was last published more than two years ago.
analysis_options.yaml. (-10 points)
Change the name of your package's
.analysis_options file to
The package description is too short. (-12 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
dart_updater.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
|Dart SDK||>=1.11.1 <3.0.0|