dart_updater 0.4.0

dart_updater #

A command line application to update the Dart SDK for Linux x64 systems.

Installation #

pub global activate dart_updater

Requirements #

To use dart_updater, you must add 2 variables to your environment variables :

  • DART_SDK_PATH : Path where the Dart SDK will be installed.

You should also have a standalone Dart version somewhere on your system to run this package. But once you run it once, you can always keep your SDK up-to-date.

Example usage #

Showing help #

$ dart_updater --help

Showing help for specific command #

$ dart_updater upgrade --help

Updating to dev/release

$ dart_updater upgrade -c dev/release

Updating to stable/release

$ dart_updater upgrade -c stable/release

Changelog #

0.4.0 #

  • Added switch to be able to install specific version of the SDK.

0.3.0 #

  • Removed Dartium support
  • Added dev compiler support
  • Updated Dependencies

0.2.0 #

  • Updated Readme/Changelog

0.1.0 #

  • Added support for environment variables for dartium and dart-sdk
  • Testing a viable version

0.0.1 #

  • Initial version, created by Stagehand

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate dart_updater

2. Use it

The package has the following executables:


$ dart_updater

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dart_updater: ^0.4.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dart_updater/dart_updater.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.4.0.
 
 Because dart_updater depends on unscripted >=0.0.2 which requires SDK version <2.0.0, version solving failed.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Use analysis_options.yaml. (-10 points)

Change the name of your package's .analysis_options file to analysis_options.yaml.

Read more about the setup of analysis-options.yaml.

Package is getting outdated. (-69.59 points)

The package was last published 88 weeks ago.

The package description is too short. (-12 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and dart_updater.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.11.1 <3.0.0

Admin