dart_style 2.3.4 copy "dart_style: ^2.3.4" to clipboard
dart_style: ^2.3.4 copied to clipboard

Opinionated, automatic Dart source code formatter. Provides an API and a CLI tool.

Use this package as an executable

Install it

You can install the package from the command line:

dart pub global activate dart_style

Use it

The package has the following executables:

$ dartfmt
$ dartformat

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add dart_style

With Flutter:

 $ flutter pub add dart_style

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  dart_style: ^2.3.4

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:dart_style/dart_style.dart';
86
likes
130
pub points
97%
popularity

Publisher

verified publishertools.dart.dev

Opinionated, automatic Dart source code formatter. Provides an API and a CLI tool.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

analyzer, args, collection, path, pub_semver, source_span

More

Packages that depend on dart_style