dart_ssh_two 0.0.3

  • README.md
  • Example
  • Installing
  • Versions
  • 0

dart_ssh_two #

A SSH2 Client library for Dart Lang

Usage #

This is currently a placeholder package! Please visit the homepage to get progress.

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

0.0.3 #

  • Updates to readme and copyright

0.0.1 #

  • Initial version, created by Stagehand


import 'package:dart_ssh_two/dart_ssh_two.dart';

main() {

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  dart_ssh_two: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:dart_ssh_two/dart_ssh_two.dart';
Version Uploaded Documentation Archive
0.0.3 Aug 13, 2016 Go to the documentation of dart_ssh_two 0.0.3 Download dart_ssh_two 0.0.3 archive
0.0.2 Aug 13, 2016 Go to the documentation of dart_ssh_two 0.0.2 Download dart_ssh_two 0.0.2 archive
0.0.1 Aug 13, 2016 Go to the documentation of dart_ssh_two 0.0.1 Download dart_ssh_two 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0