dart_otp 1.3.0
dart_otp: ^1.3.0 copied to clipboard

dart_otp is a dart package to generate and verify one-time passwords.

example/example.dart

import 'package:dart_otp/dart_otp.dart';

void main() {
  TOTP totp = TOTP(secret: "J22U6B3WIWRRBTAV");
  HOTP hotp = HOTP(secret: "J22U6B3WIWRRBTAV");

  print(totp.now());
  print(totp.value(date: DateTime.parse('2019-01-01 00:00:00.000')));

  print(hotp.at(counter: 0));
  print(hotp.at(counter: 2019));
}
8
likes
100
pub points
77%
popularity

dart_otp is a dart package to generate and verify one-time passwords.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

brunofilipemiguens@gmail.com

License

MIT (LICENSE)

Dependencies

base32, crypto

More

Packages that depend on dart_otp