dart_ng 0.0.1

dart-ng #

A basic command-line application for AngularDart that try to emulate ng from package @angular/cli (typescript)

Activate from github :

pub global activate --source git https://github.com/alescdb/dart-ng

Activate from sources :

pub global activate --source path .

Deactivate package :

pub global deactivate dart_ng

Usage :

dart-ng <component|pipe|service> <name>

eg create a component HelloWorldComponent :

shell> dart-ng component helloWorld

Upper Name : HelloWorld, Lower Name : helloworld
Create directory : helloworld
Writing template : lib\helloworld\helloworld.html
Writing template : lib\helloworld\helloworld.dart
Writing template : lib\helloworld\helloworld.scss

Use this package as an executable

1. Install it

You can install the package from the command line:

$ pub global activate dart_ng

2. Use it

The package has the following executables:

$ dart-ng

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  dart_ng: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:dart_ng/filename.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0