dart_math 0.0.4

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 20

DartMath #

A simple dart Math Library #

0.0.1 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dart_math: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dart_math/dart_math.dart';
  
Version Uploaded Documentation Archive
0.0.9+3 Dec 26, 2018 Go to the documentation of dart_math 0.0.9+3 Download dart_math 0.0.9+3 archive
0.0.9+2 Dec 26, 2018 Go to the documentation of dart_math 0.0.9+2 Download dart_math 0.0.9+2 archive
0.0.9+1 Dec 26, 2018 Go to the documentation of dart_math 0.0.9+1 Download dart_math 0.0.9+1 archive
0.0.9 Aug 25, 2018 Go to the documentation of dart_math 0.0.9 Download dart_math 0.0.9 archive
0.0.8 Aug 25, 2018 Go to the documentation of dart_math 0.0.8 Download dart_math 0.0.8 archive
0.0.7 Aug 23, 2018 Go to the documentation of dart_math 0.0.7 Download dart_math 0.0.7 archive
0.0.6 Aug 21, 2018 Go to the documentation of dart_math 0.0.6 Download dart_math 0.0.6 archive
0.0.5 Aug 21, 2018 Go to the documentation of dart_math 0.0.5 Download dart_math 0.0.5 archive
0.0.4 Aug 21, 2018 Go to the documentation of dart_math 0.0.4 Download dart_math 0.0.4 archive
0.0.3 Aug 21, 2018 Go to the documentation of dart_math 0.0.3 Download dart_math 0.0.3 archive

All 12 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
36
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
10
Overall:
Weighted score of the above. [more]
20
Learn more about scoring.

We analyzed this package on May 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.0
  • pana: 0.12.15

Platforms

Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.3.0.
 
 Because dart_math requires SDK version 2.0.0, version solving failed.

Health suggestions

Format lib/circle.dart.

Run dartfmt to format lib/circle.dart.

Format lib/cordinates.dart.

Run dartfmt to format lib/cordinates.dart.

Format lib/fractions.dart.

Run dartfmt to format lib/fractions.dart.

Format lib/lines.dart.

Run dartfmt to format lib/lines.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Support the latest stable Dart SDK in pubspec.yaml. (-20 points)

The SDK constraint in pubspec.yaml doesn't allow the latest stable Dart SDK release.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and dart_math.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK 2.0.0