dart_lol 0.0.5

  • Readme
  • Changelog
  • Installing
  • 46

dart_lol, the one good league of legends plugin for flutter #

A German package production :D im 17 btw!!!

Introduction / Einführung #

This is a simple good package for using the League of Legends API (will reference it as LoLApi)

This package is not yet finished an experimental! Please submit any bugs to my github repository and I will try the best in my hands to fix the g0d d4mn3d 3rr0r!

I am going to keep it simple! How to use it properly:

First you have to assign a ApiToken given by LoLApi (You need to wait approximately 3 weeks to get your project verified! Register yours here)

final league = League(apiToken: apiToken);

and furthermore

league.getSummonerInfo(summonerName: 'Ÿurt').then((summonerInfo){
    print(summonerInfo.summonerName);
    // Outputs Ÿurt
    print(summonerInfo.level);
    // Outputs current summoner level
    // etc.
  });

A bigger example to how to use my League package (maybe you can see how it actually appeals with the flutter-ish style :D)

league.getSummonerInfo(summonerName: emre).then((id) {
    final game = league.getGameHistory(accountID: id.accID);
    game.then((gameStat) {

      print(gameStat[1].championName);
      // Always outputs your stats for any game in the List of GameStat

      gameStat[2].stats().then((ok) {

        print(ok.participants[1].summonerName);
        // Outputs the second summoners name
        league
            .getRankInfos(summonerID: ok.participants[6].summonerID)
            .then((rankInfo) {

          print(rankInfo.leaguePoints);
          print(rankInfo.tier);
          // Outputs the sixth summoners current league points and his current tier
        });
      });
    });
  });

If you like my repo and want to help me or whatever, please contact me via Discord or Telegram:

Discord: AaronFanEmre#7866

Telegram: emredev

Thank you very much! Special thanks to you, Flutter! Danke an alle, dass ihr hier seid!

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[0.0.1] - Initial Release :D #

[0.0.2] - Now: WIN option available! -> getGameHistory #

[0.0.3] - Now: Kills/Deaths/Assists option available! -> getGameHistory #

[0.0.4] - Now: CS option available! -> getGameHistory #

[0.0.5] - Now: Items option available! -> getGameHistory #

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dart_lol: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dart_lol/dart_lol.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Mar 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health suggestions

Format lib/LeagueStuff/game.dart.

Run flutter format to format lib/LeagueStuff/game.dart.

Format lib/dart_lol.dart.

Run flutter format to format lib/dart_lol.dart.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and dart_lol.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
http ^0.12.0+3 0.12.0+4
Transitive dependencies
async 2.4.1
charcode 1.1.3
collection 1.14.11 1.14.12
http_parser 3.1.4
meta 1.1.8
path 1.6.4
pedantic 1.9.0
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test