dart_init 0.0.1

便捷生成 dart 项目 #

将当前项目注册到本地路径

# pubspec.yaml
# 此时运行的是 dart_init/bin/main.dart
executables:
  dart_init: main
$ pub global activate --source path ./ --overwrite

使用本地命令执行:

$ dart_init ...
# 或
$ pub global run dart_init:main

查看帮助 #

$ dart_init --help

[0.0.1] - 创建工程

  • TODO: 发布项目

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate dart_init

2. Use it

The package has the following executables:


$ dart_init
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Jul 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
args ^1.5.2 1.5.2
path ^1.6.2 1.6.2

Admin