dart_discord_rpc 0.0.2
dart_discord_rpc: ^0.0.2 copied to clipboard

Discord Rich Presence for Flutter & Dart apps & games.

dart_discord_rpc

Discord Rich Presence for Flutter & Dart apps & games.



Install #

Flutter

dependencies:
  ..
  dart_discord_rpc: ^0.0.1

Dart CLI

dependencies:
  ..
  dart_discord_rpc_ffi: ^0.0.1

Documentation #

For integrating Discord Rich Presence into your application or game, you must create an application at Discord Developer Portal.

Initialize the plugin.

void main() {
    DiscordRPC.initialize();
    runApp(MyApp());
}

Instantiate class.

DiscordRPC rpc = DiscordRPC(
    applicationId: 'APPLICATION_ID',
);

Set or change the user presence.

rpc.start(autoRegister: true);
rpc.updatePresence(
    DiscordPresence(
        state: 'Discord Rich Presence from Dart. 🎯',
        details: 'github.com/alexmercerind/dart_discord_rpc',
        startTimeStamp: DateTime.now().millisecondsSinceEpoch,
        largeImageKey: 'large_image',
        largeImageText: 'This text describes the large image.',
        smallImageKey: 'small_image',
        smallImageText: 'This text describes the small image.',
    ),
);

Clear the user presence.

rpc.clearPresence();

Listen to the events.

rpc.events.listen((event) {
    if (event is DiscordReady) {
        event.user;
    }
    if (event is DiscordErrored) {
        event.errorCode;
        event.message;
    }
    if (event is DiscordJoinGame) {
        event.joinSecret;
    }
    // Other events.
});

There are other features for you to checkout.

Support #

Consider supporting the project by starring the repository or buying me a coffee.

License #

Copyright (c) 2021 Hitesh Kumar Saini saini123hitesh@gmail.com

MIT. Contributions welcomed.

Platforms #

Supported

  • Windows

Coming Soon

  • Linux
  • Android

Unsupported

  • macOS
  • iOS
1
likes
100
pub points
69%
popularity

Discord Rich Presence for Flutter & Dart apps & games.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dart_discord_rpc_ffi, flutter, path

More

Packages that depend on dart_discord_rpc