dart_dartrix 0.2.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 50

dart_dartrix #

Dartrix template library of Dart code.

To be used as a Dartrix plugin.

To install:

0.2.3 #

  • add example

0.2.2 #

  • fix cmd_shell, to version 0.2.1

0.2.1 #

  • update to dartrix 0.2.0

0.2.0 #

  • remove beta tag and bump to 0.2.0

0.1.3-beta #

  • fix bug in dart_dartrix.dart

0.1.2-beta #

  • chg name from null.dart to dart_dartrix.dart to make pub.dev happy

0.1.1-beta #

  • Add lib/null.dart to avoid "No valid SDK" bug in pub.dev

0.1.0-beta #

  • Initial version pushed to pub.dev

example/main.dart

// placeholder for pub.dev - this is not an executable lib

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dart_dartrix: ^0.2.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dart_dartrix/dart_dartrix.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Jul 14, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15

Analysis suggestions

Package not compatible with runtime flutter-web on Web

Because:

  • package:dart_dartrix/dart_dartrix.dart that imports:
  • dart:isolate

Package not compatible with runtime js

Because:

  • package:dart_dartrix/dart_dartrix.dart that imports:
  • dart:isolate

Health issues and suggestions

Document public APIs. (-1 points)

2 out of 2 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
args ^1.5.3 1.6.0