dart_arango_min 0.0.4

  • Readme
  • Changelog
  • Example
  • Installing
  • 66

ArangoDB driver for Dart. (in development, not for production)

0.0.1-dev.0.1 #

  • Initial version, created by Stagehand

0.0.1-dev.0.2 #

  • MVP realised

0.0.1-dev.0.3 #

  • FIX return type

0.0.1-dev.0.4 #

  • queryToListOfMap() method was added.

0.0.1-dev.0.5 #

  • queryToListOfMap() -> queryToList() and query() -> queryToStream()

0.0.1-dev.0.6 #

  • type of elements of queryToList() and queryToStream() is dynamic

0.0.1-dev.0.7 #

  • try to count bytes

0.0.1-dev.0.8 #

  • throws error if query iresult has error

0.0.2 #

  • Query() constructor

0.0.3 #

  • delete FromList() constructor

0.0.4 #

  • fix toMap() return type


import 'package:dart_arango_min/dart_arango_min.dart';

main() {
  var awesome = Awesome();
  print('awesome: ${awesome.isAwesome}');

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  dart_arango_min: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:dart_arango_min/dart_arango_min.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4

Health suggestions

Format lib/src/dart_arango_min_base.dart.

Run dartfmt to format lib/src/dart_arango_min_base.dart.

Format lib/src/dart_arango_min_query.dart.

Run dartfmt to format lib/src/dart_arango_min_query.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-8 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.5.0 <3.0.0
Dev dependencies
pedantic ^1.8.0
test ^1.6.0