darksky_weather 1.4.0+1

darksky_weather Dart CI

A dart library for interfacing with the Dark Sky Weather API.

Usage #

A simple usage example:

import 'dart:async';
import 'package:darksky_weather/darksky_weather_io.dart';

Future<Null> main() async {
  var darksky = new DarkSkyWeather("API_KEY_HERE",
      language: Language.German, units: Units.SI);
  var forecast = await darksky.getForecast(48.21, 16.363);

  print(forecast.currently.temperature);
  print(forecast.currently.summary);
}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

1.4.0 #

  • add flags and alerts

1.3.0 #

  • upgrade to json_annotation 3.0.0

1.2.0 #

  • add timemachine feature

1.1.0 #

  • add tests
  • make pub analyzer happy

1.0.0 #

0.1.1 #

  • fix deserialisation issues
  • fix readme
  • refactor code and add options

0.1.0 #

  • first version of the api implementation

0.0.1 #

  • initial version

example/example.dart

// Copyright (c) 2017, 'rinukkusu'. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'dart:async';
import 'package:darksky_weather/darksky_weather_io.dart';

Future<Null> main() async {
  var darksky = new DarkSkyWeather("API_KEY_HERE",
      language: Language.German, units: Units.SI);
  var forecast = await darksky.getForecast(48.21, 16.363);

  print(forecast.currently.temperature);
  print(forecast.currently.summary);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  darksky_weather: ^1.4.0+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:darksky_weather/darksky_weather_browser.dart';
import 'package:darksky_weather/darksky_weather_browser.g.dart';
import 'package:darksky_weather/darksky_weather_io.dart';
import 'package:darksky_weather/darksky_weather_io.g.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
70
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
84
Learn more about scoring.

We analyzed this package on Feb 12, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Health suggestions

Fix lib/src/darksky_weather_base.dart. (-0.50 points)

Analysis of lib/src/darksky_weather_base.dart reported 1 hint:

line 58 col 20: Unnecessary new keyword.

Fix lib/src/darksky_weather_browser.dart. (-0.50 points)

Analysis of lib/src/darksky_weather_browser.dart reported 1 hint:

line 12 col 18: Unnecessary new keyword.

Fix lib/src/darksky_weather_io.dart. (-0.50 points)

Analysis of lib/src/darksky_weather_io.dart reported 1 hint:

line 12 col 18: Unnecessary new keyword.

Fix additional 7 files with analysis or formatting issues. (-1 points)

Additional issues in the following files:

  • lib/src/enums/language_enum.dart (1 hint)
  • lib/src/enums/units_enum.dart (1 hint)
  • lib/src/models/alert.dart (Run dartfmt to format lib/src/models/alert.dart.)
  • lib/src/models/datablock.dart (Run dartfmt to format lib/src/models/datablock.dart.)
  • lib/src/models/datapoint.dart (Run dartfmt to format lib/src/models/datapoint.dart.)
  • lib/src/models/flags.dart (Run dartfmt to format lib/src/models/flags.dart.)
  • lib/src/models/forecast.dart (Run dartfmt to format lib/src/models/forecast.dart.)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
http ^0.12.0 0.12.0+4
json_annotation ^3.0.0 3.0.1
Transitive dependencies
async 2.4.0
charcode 1.1.3
collection 1.14.12
http_parser 3.1.3
meta 1.1.8
path 1.6.4
pedantic 1.9.0
source_span 1.6.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
build_runner ^1.1.2
json_serializable ^3.0.0
test ^1.3.0