darequest 0.2.2

darequest #

dart request lib

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  darequest: ^0.2.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:darequest/exceptions/response_exception.dart';
import 'package:darequest/interceptor/interceptor.dart';
import 'package:darequest/request.dart';
import 'package:darequest/request_option.dart';
import 'package:darequest/response.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 13, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.7.1.
 Because darequest requires SDK version >=1.24.0 <=2.0.0, version solving failed.

Health suggestions

Format lib/exceptions/response_exception.dart.

Run dartfmt to format lib/exceptions/response_exception.dart.

Format lib/interceptor/interceptor.dart.

Run dartfmt to format lib/interceptor/interceptor.dart.

Format lib/request.dart.

Run dartfmt to format lib/request.dart.

Format lib/request_option.dart.

Run dartfmt to format lib/request_option.dart.

Format lib/response.dart.

Run dartfmt to format lib/response.dart.

Maintenance issues and suggestions

Support future stable Dart 2 SDKs in pubspec.yaml. (-20 points)

The SDK constraint in pubspec.yaml doesn't allow future stable Dart 2.x SDK releases.

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Package is getting outdated. (-93.15 points)

The package was last published 100 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and darequest.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <=2.0.0