danplayer 0.0.3+1

  • Readme
  • Changelog
  • Example
  • Installing
  • new47

DanPlayer #

一个Flutter弹幕播放器 #

A Flutter DanMaku Player #

网页版 / HTML Version #

截图 / Screenshots #

todo

特点 / Features #

  • 完善的弹幕功能

    Danmaku Danmaku Danmaku!

  • UI高自由度的自定义选项,包括:

    blahblahblah

    • 视频进度条的指示器,你可以换成图片
    • 视频进度条的播放进度、缓存进度的颜色
    • UI上下部分的背景颜色
    • 读取时的提示样式

[0.0.3+1]

修复渲染视频比例的问题

[0.0.3]

上下滑动调整音量

左右滑动改变播放进度

[0.0.2+hotfix1]

直播模式下隐藏进度条

[0.0.2]

  • 完成基础界面
  • 弹幕相关功能仍未实现
  • 请使用 DanPlayerConfig.danmaku=false 屏蔽弹幕相关按钮
  • 更新License

[0.0.1]

初始化

example/README.md

example #

A DanPlayer Example

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  danplayer: ^0.0.3+1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:danplayer/danplayer.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
84
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

We analyzed this package on Nov 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The description is too long. (-6 points)

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0 <3.0.0
flutter 0.0.0
video_player ^0.10.2+5 0.10.2+5
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test