dacsslide 0.3.1+1

  • Readme
  • Changelog
  • Installing
  • 2

DaCSSlide Build Status

Port of JaCSS - tiny "framework" for building pure CSS3-animation based presentations.

Examples #

Advanced usage:

Example #

Example could be found in web folder.

In HTML file you need to speicfy "symbols":

<presentation slides="8" class="hidden">
      <symbol id="hello">
        Hello {{world}}
      </symbol>
      <symbol id="center">
        Center
      </symbol>
</presentation>

And in SCSS file you need to specify behaviour (Note: syntax below is using DACSSlide additions to SCSS):

#center {
  opacity:0;
}
.s2 {
  #hello: move(50,100);
   
  #center {
    background-color:red;
    opacity:1;
    ::up(20);
  }
}
.s3 {
  #hello:move(+100,+100);
}
...

Where .sN means behaviour for slide (keyframe) N.

Each symbol can have track property if it can change it's width or height (in case of asynchronously loaded symbols).

How to run #

You can start webdev serve and open http://localhost:8080

Changelog #

##0.3.1

Updated dependencies and sample web page to support dart 2.0+

##0.3.0-beta

Updated to 5.0-beta+11. Changed transformers to builders

BREAKING CHANGE Now instead of "scss" files "pcss" files are used for specifying slide transitions

##0.3.0-alpha

Upgraded to Angular 5.0 and using dartdevc. Initial dacsslide binary implementation.

##0.2.1

Added speaker comments support. Just add

<comment slide="1">Some comment</comment>

##0.2.0

Added possibility to change units. put anywhere

/* dacsslide.units = vmax */

All transform operators will use that units.

BREAKING CHANGE Now if modifier has several parameters but was called with less, it will use last specified parameter (previously it used X-axis). E.g. scale(2) will produce scaleX(2) scaleY(2) and not just scaleX(2) like before. Same for rotate. Please add axis modifier to have previous behavior.

BREAKING CHANGE scale modifier now accept 2 parameters (X and Y). If you need scaling on Z-axis, you can use scaleZ.

##0.1.3

Switched to Angular 4.

##0.1.2

Adding event listeners directly, not through EventManager. DDC friendly.

##0.1.1

Angular 2.

0.0.15 #

  • Added support of additional parameters in URL hash (Appended by &). Could be used by other plugins, like remote controller.

0.0.14 #

  • Tracking symbols by default. Symbols can be not auto-centralized by setting fixed=true on symbol.

0.0.12 #

  • Aded "track" property to track symbol's width/height.

0.0.11 #

  • Aded inline syntax. Added opacity function.

0.0.10 #

  • Aded delay functions. Removed relative modifier for move. Added documentation for functions.

0.0.9 #

  • Added shortened relative modifiers (up, down, left, right) and tests

0.0.8 #

  • Added DACSSlie extension to SCSS syntax

0.0.7 #

  • Added CSSLib transform so now it is possible to use nested CSS rules and other features provided by CSSLib

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dacsslide: ^0.3.1+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dacsslide/builder.dart';
import 'package:dacsslide/pcss_builder.dart';
import 'package:dacsslide/presentation_component.dart';
import 'package:dacsslide/sample_directive.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
12
Overall:
Weighted score of the above. [more]
2
Learn more about scoring.

We analyzed this package on Oct 18, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21

Platforms

Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.5.1.
 
 Because dacsslide requires SDK version >=2.0.0 <=2.2.0, version solving failed.

Health suggestions

Format bin/dacsslide.dart.

Run dartfmt to format bin/dacsslide.dart.

Format lib/builder.dart.

Run dartfmt to format lib/builder.dart.

Format lib/pcss_builder.dart.

Run dartfmt to format lib/pcss_builder.dart.

Format lib/presentation_component.dart.

Run dartfmt to format lib/presentation_component.dart.

Format lib/sample_directive.dart.

Run dartfmt to format lib/sample_directive.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Support future stable Dart 2 SDKs in pubspec.yaml. (-20 points)

The SDK constraint in pubspec.yaml doesn't allow future stable Dart 2.x SDK releases.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and dacsslide.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is getting outdated. (-8.49 points)

The package was last published 56 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <=2.2.0