daassets 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 64

Daassets #

A Flutter package to automatically generate a class containing references to all assets in your project.

Installation #

Add the following dependencies to your pubspec.yaml:

  daassets: ^1.0.0

Example #

Define your assets #

In your pubspec.yaml file:



    - assets/icon/            # imports all files in that directory
    - assets/icon/close.png   # imports that specific file

Generating Dart code #

To generate the Dart file containing all assets, run the following command:

flutter pub pub run daassets:daassets.dart PUBSPEC_FILE_PATH OUTPUT_FILE_PATH

For example:

flutter pub pub run daassets:daassets.dart ./pubspec.yaml ./lib/assets.dart

Using generated code #

The generated class contains static constants that you can use anywhere in your project.


[1.0.0] - 2019-08-08

  • First version


Example #

Example available in the main README.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  daassets: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:daassets/daassets.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health issues and suggestions

Document public APIs. (-1 points)

1 out of 1 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.4.0 <3.0.0
flutter 0.0.0
yaml ^2.1.16 2.2.0
Transitive dependencies
charcode 1.1.2
collection 1.14.11 1.14.12
meta 1.1.8
path 1.6.4
sky_engine 0.0.99
source_span 1.6.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8