custom_splash_screen 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 78

custom_splash_screen #

a flutter package for both android and ios that checks internet connection in splash screen and makes custom splash screens for your applications.

Screenshots #

Usage #

[Example](in source)

To use this plugin :

  • add the dependency to your [pubspec.yaml) file.
  dependencies:
    flutter:
      sdk: flutter
    custom_splash_screen:

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.0.1] - Release

  • A customizable splash screen that checks connectivity.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  custom_splash_screen: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:custom_splash_screen/custom_splash_screen.dart';
  
Version Uploaded Documentation Archive
0.0.1 Oct 15, 2018 Go to the documentation of custom_splash_screen 0.0.1 Download custom_splash_screen 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
67
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
75
Overall:
Weighted score of the above. [more]
78
Learn more about scoring.

We analyzed this package on Jun 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/custom_splash_screen.dart.

Run flutter format to format lib/custom_splash_screen.dart.

Maintenance issues and suggestions

Support latest dependencies. (-15 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (1 direct: connectivity).

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and custom_splash_screen.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
connectivity ^0.3.2 0.3.2 0.4.3+2
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test