currency_icons 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 78

currency-icons #

A Dart package with many currency icons.

How to use? #

Image.asset('icons/currency/${currency}.png', package: 'currency_icons');

Credits #

All icons are used from transferwise

This package is inspired from country_icons

0.1.0 #

  • Add example
  • Specify only for flutter
  • Specify Dart 2 only

0.0.1 #

  • Add currency icons


import 'package:flutter/material.dart';

class Currency extends StatelessWidget {
  // init Currency
  final String currencyName;

  Currency({Key key, @required this.currencyName}) : super(key: key);

  Widget build(BuildContext context) {
    return new Card(
      child: new Column(
        mainAxisSize: MainAxisSize.min,
        children: <Widget>[
              leading: Image.asset('icons/currency/${this.currencyName}.png',
                  package: 'currency_icons'),
              title: Text(this.currencyName)),

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  currency_icons: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Oct 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Package is getting outdated. (-24.66 points)

The package was last published 65 weeks ago.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.55.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_launcher_icons ^0.5.2