cuber 0.4.0 copy "cuber: ^0.4.0" to clipboard
cuber: ^0.4.0 copied to clipboard

Dart implementation of Herbert Kociemba's two-phase algorithm for solving Rubik's Cube.

0.4.0 #

  • Dart SDK >= 2.17.

0.3.0 #

  • Null safety support.

0.2.0 #

  • Implement auto-reorientation when using Cube.from and Cube.of.
  • Support to generate SVG image of the cube.
  • Add more predefined patterns.

0.1.1 #

  • Drop dart:isolate dependency to support Flutter Web.
  • Minor bug fix.

0.1.0 #

  • Initial release.
16
likes
130
pub points
50%
popularity

Publisher

verified publishertiagohm.dev

Dart implementation of Herbert Kociemba's two-phase algorithm for solving Rubik's Cube.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

equatable

More

Packages that depend on cuber