cryptor 0.1.5

  • Readme
  • Changelog
  • Example
  • Installing
  • new65

cryptor #

AES-GCM-256 algorithm cryptor

Usage #

  var text = 'SOME DATA TO ENCRYPT';
  var password = 'password';

  var encrypted = Cryptor.encrypt(text, password);
  var decrypted = Cryptor.decrypt(encrypted, password);

  print(encrypted);
  print(decrypted);

[0.1.5] - Fix pbkdf2 and improvements #

  • Fix pbkdf2 to generate correct key
  • Reduce number of type conversions
  • Add hash function to hash password

[0.1.4] - API Change #

  • encrypt and decrypt are now static methods of Cryptor
  • Implement AesGcm module

[0.1.3] - Implement PBKDF2 #

  • Implement PBKDF2
  • Get rid of hash_password dependency

[0.1.2] - Initial implementation of AES GCM cryptor #

  • Rename example file to be inline with guidelines

[0.1.1] - Initial implementation of AES GCM cryptor #

  • Add dart doc comments to the code
  • Add expample/aes.dart
  • Formatted lib/cryptor.dart

[0.1.0] - Initial implementation of AES GCM cryptor #

  • Add ecnrypt and decrypt functions

example/cryptor.dart

import 'package:cryptor/cryptor.dart';

void main() {
  final text = 'SOME DATA TO ENCRYPT';
  final password = 'password';

  final encrypted = Cryptor.encrypt(text, password);
  final decrypted = Cryptor.decrypt(encrypted, password);

  print(encrypted);
  print(decrypted);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  cryptor: ^0.1.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:cryptor/cryptor.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
34
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
65
Learn more about scoring.

We analyzed this package on May 30, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.2
  • pana: 0.13.8-dev
  • Flutter: 1.17.1

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (steel_crypt).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
crypto ^2.1.4 2.1.5
flutter 0.0.0
steel_crypt ^1.7.1+1 1.7.1+1 2.0.0
Transitive dependencies
args 1.6.0
asn1lib 0.6.4
charcode 1.1.3
collection 1.14.12
convert 2.1.1
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test