crossfire_web 2.1.0

  • Readme
  • Changelog
  • Installing
  • 57

crossfire_web #

Cross-platform APIs for Firebase.

see the project page for usage examples

2.1.0 #

  • add startsAfter

Thanks to @leftyio for this release!

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  crossfire_web: ^2.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:crossfire_web/crossfire_web.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
40
Health:
Code health derived from static analysis. [more]
84
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
57
Learn more about scoring.

We analyzed this package on Dec 7, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21

Platforms

Detected platforms: web

Primary library: package:crossfire_web/crossfire_web.dart with components: html, js.

Health issues and suggestions

Document public APIs. (-1 points)

68 out of 68 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/crossfire_web.dart. (-15.25 points)

Analysis of lib/crossfire_web.dart reported 33 hints, including:

line 16 col 43: Unnecessary new keyword.

line 24 col 17: Avoid empty catch blocks.

line 39 col 9: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

line 51 col 12: Unnecessary new keyword.

line 57 col 12: Unnecessary new keyword.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (firebase).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and crossfire_web.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
crossfire ^2.1.0 2.1.0
firebase ^5.0.0 5.0.4 7.1.0
jsifier ^2.0.0 2.0.0
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.12
http 0.12.0+2
http_parser 3.1.3
js 0.6.1+1
meta 1.1.8
path 1.6.4
pedantic 1.9.0
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
test ^1.3.0