cpp_binding_generator 0.0.0

cpp_binding_generator #

Builder for generating C++ classes and extension entrypoint for Dart.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  cpp_binding_generator: ^0.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:cpp_binding_generator/cpp_binding_generator.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
56
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
17
Learn more about scoring.

We analyzed this package on Mar 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Health issues and suggestions

Fix lib/src/extension_builder.dart. (-38.01 points)

Analysis of lib/src/extension_builder.dart failed with 1 error, 38 hints, including:

line 50 col 26: The method 'computeNode' isn't defined for the class 'CompilationUnitElement'.

line 16 col 5: Avoid const keyword.

line 18 col 25: Unnecessary new keyword.

line 38 col 16: Unnecessary new keyword.

line 47 col 21: Unnecessary new keyword.

Fix lib/src/binding_class_builder.dart. (-25 points)

Analysis of lib/src/binding_class_builder.dart reported 163 hints, including:

line 27 col 15: Unnecessary new keyword.

line 34 col 16: Unnecessary new keyword.

line 37 col 20: Unnecessary new keyword.

line 39 col 11: Unnecessary new keyword.

line 40 col 11: Unnecessary new keyword.

Fix lib/src/cpp_gen.dart. (-4.89 points)

Analysis of lib/src/cpp_gen.dart reported 10 hints, including:

line 13 col 13: Unnecessary new keyword.

line 38 col 13: Unnecessary new keyword.

line 59 col 7: Unnecessary new keyword.

line 76 col 13: Unnecessary new keyword.

line 101 col 13: Unnecessary new keyword.

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (build_config, recase).

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: analyzer.

Package is getting outdated. (-37.26 points)

The package was last published 71 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and cpp_binding_generator.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev <3.0.0
analyzer any 0.39.4
build >=0.12.0 <2.0.0 1.2.2
build_config ^0.3.0 0.3.2 0.4.2
c_builder ^1.0.0 1.1.0
code_buffer ^1.0.0 1.0.1
cpp_binding ^0.0.0 0.0.0
path ^1.0.0 1.6.4
recase ^2.0.0 2.0.1 3.0.0
source_gen ^0.9.0 0.9.5
Transitive dependencies
_fe_analyzer_shared 1.0.3
args 1.6.0
async 2.4.1
charcode 1.1.3
checked_yaml 1.0.2
collection 1.14.12
convert 2.1.1
crypto 2.1.4
csslib 0.16.1
dart_style 1.3.3
glob 1.2.0
html 0.14.0+3
js 0.6.1+1
json_annotation 2.4.0 3.0.1
logging 0.11.4
meta 1.1.8
node_interop 1.0.3
node_io 1.0.1+2
package_config 1.9.3
pedantic 1.9.0
pub_semver 1.4.4
pubspec_parse 0.1.5
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+14
yaml 2.2.0
Dev dependencies
build_runner ^1.0.0
test ^1.0.0