core_plugin 0.2.20

  • Readme
  • Changelog
  • Example
  • Installing
  • 67

core_plugin #

A new flutter plugin project.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

0.2.20 #

update FlutterRoutingManager

0.2.19 #

update FlutterRoutingManager

0.2.18 #

update FlutterRoutingManager

0.2.17 #

add new tracking firebase

0.2.16 #

add getAmountOfCartItems function

0.2.15 #

add RouteNameManager.dart

0.2.14 #

  • Update tracking RAD.

0.0.1 #

  • TODO: Describe initial release.

example/README.md

core_plugin_example #

Demonstrates how to use the core_plugin plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  core_plugin: ^0.2.20

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:core_plugin/core_plugin.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
53
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Oct 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Fix lib/RouteNameManager.dart. (-6.42 points)

Analysis of lib/RouteNameManager.dart reported 1 warning, 3 hints:

line 31 col 31: The parameter 'arguments' is required.

line 23 col 10: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 29 col 10: This function has a return type of 'Future

line 29 col 10: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Document public APIs. (-1 points)

285 out of 285 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/tracking/channel_tracking_manager.dart. (-2.48 points)

Analysis of lib/tracking/channel_tracking_manager.dart reported 5 hints:

line 23 col 39: Avoid using braces in interpolation when not needed.

line 37 col 39: Avoid using braces in interpolation when not needed.

line 50 col 40: Avoid using braces in interpolation when not needed.

line 64 col 43: Avoid using braces in interpolation when not needed.

line 73 col 37: Avoid using braces in interpolation when not needed.

Fix lib/helper.dart. (-0.50 points)

Analysis of lib/helper.dart reported 1 hint:

line 4 col 53: Avoid using braces in interpolation when not needed.

Fix additional 11 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/Cart.dart (Run flutter format to format lib/Cart.dart.)
  • lib/base_model.dart (Run flutter format to format lib/base_model.dart.)
  • lib/base_proxy.dart (Run flutter format to format lib/base_proxy.dart.)
  • lib/checkout/channel_user_manager.dart (Run flutter format to format lib/checkout/channel_user_manager.dart.)
  • lib/config.dart (Run flutter format to format lib/config.dart.)
  • lib/core_plugin.dart (Run flutter format to format lib/core_plugin.dart.)
  • lib/http_utility.dart (Run flutter format to format lib/http_utility.dart.)
  • lib/tracking/tracking_manager.dart (Run flutter format to format lib/tracking/tracking_manager.dart.)
  • lib/user/channel_user_manager.dart (Run flutter format to format lib/user/channel_user_manager.dart.)
  • lib/user/user_info.dart (Run flutter format to format lib/user/user_info.dart.)
  • lib/user/user_preference.dart (Run flutter format to format lib/user/user_preference.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (shared_preferences).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
shared_preferences ^0.4.2 0.4.3 0.5.4
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8