cordova_googleplus_plugin 1.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 50

Dart Wrapper for Cordova Googleplus Plugin #

if you would like to use this plugin: https://github.com/EddyVerbruggen/cordova-plugin-googleplus with dart. Install this package.

In you code just import GoogleplusPlugin, and watch the available methods. They are exactly the same like on cordova repo.

Remember to install the cordova plugin also!! this is just a wrapper

pub package: https://pub.dartlang.org/packages/cordova_googleplus_plugin

installation: #

add this to your dependencies

dependencies:
  cordova_googleplus_plugin: ^1.0.0

import #

import 'package:cordova_googleplus_plugin/cordova_googleplus_plugin.dart';

1.0.1 02.01.2019 #

-change readme and add this changelog

1.0.0 02.01.2019 #

-first initial working version of this plugin

example/main.dart

import 'dart:html';

import 'package:cordova_googleplus_plugin/cordova_googleplus_plugin.dart';

String CLIENT_ID = 'your google client it';

void main() {
  GoogleplusPlugin googleplus = GoogleplusPlugin(webClientId: CLIENT_ID);

  googleplus
      .trySilentLogin()
      .then((GoogleplusPayload payload) => print(payload.email));

  document.getElementById('something').onClick.listen((MouseEvent event) {
    googleplus
        .login()
        .then((GoogleplusPayload payload) => print(payload.email));
  });
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  cordova_googleplus_plugin: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:cordova_googleplus_plugin/cordova_googleplus_plugin.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Dec 9, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21

Health issues and suggestions

Document public APIs. (-1 points)

31 out of 31 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
js >=0.6.0 <0.7.0 0.6.1+1