cordova 1.0.2

  • Readme
  • Changelog
  • Installing
  • 40

Dart Wrapper for Cordova #

If you would like to use cordova events in your app, use this package.

import Cordova from this package and you ready to go!

pub package #

https://pub.dartlang.org/packages/cordova

installation #

dependencies:
  cordova: ^1.0.1

import #

import 'package:cordova/cordova.dart';

supported events #

  • deviceready
  • backbutton
  • menubutton
  • pause
  • resume

[1.0.2] = 2019-02-09 #

Add #

  • isExist, check if cordova object exist in window object

[1.0.1] - 2018-12-30 #

Fixed #

  • change source of event listener from window object to document

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  cordova: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:cordova/cordova.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
51
Overall:
Weighted score of the above. [more]
40
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1

Analysis suggestions

Package not compatible with runtime flutter-native of android

Because of the import of dart:js via the import chain package:cordova/cordova.dart->package:cordova/src/cordova.dart->dart:js

Package not compatible with runtime flutter-native of ios

Because of the import of dart:js via the import chain package:cordova/cordova.dart->package:cordova/src/cordova.dart->dart:js

Package not compatible with runtime flutter-native of linux

Because of the import of dart:js via the import chain package:cordova/cordova.dart->package:cordova/src/cordova.dart->dart:js

Package not compatible with runtime flutter-native of macos

Because of the import of dart:js via the import chain package:cordova/cordova.dart->package:cordova/src/cordova.dart->dart:js

Package not compatible with runtime flutter-native of windows

Because of the import of dart:js via the import chain package:cordova/cordova.dart->package:cordova/src/cordova.dart->dart:js

Package not compatible with runtime native-aot

Because of the import of dart:js via the import chain package:cordova/cordova.dart->package:cordova/src/cordova.dart->dart:js

Package not compatible with runtime native-jit

Because of the import of dart:js via the import chain package:cordova/cordova.dart->package:cordova/src/cordova.dart->dart:js

Health suggestions

Fix lib/src/cordova.dart. (-1 points)

Analysis of lib/src/cordova.dart reported 2 hints:

line 7 col 37: Unnecessary new keyword.

line 30 col 33: Unnecessary new keyword.

Maintenance suggestions

Package is getting outdated. (-39.18 points)

The package was last published 72 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and cordova.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
Dev dependencies
build_runner ^1.1.2
build_web_compilers ^0.4.4
test ^1.5.1