convex_bottom_navigation 1.1.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 72

convex_bottom_navigation #

Bottom navigation with convex items

How to use #

ConvexBottomNavigation fn = ConvexBottomNavigation(
      tabs: [
        TabData(icon: Icon(Icons.home), title: "Home"),
        TabData(icon: Icon(Icons.menu), title: "Menu")
      ],
      onTabChangedListener: (position) {},
    );

Or, for example:

ConvexBottomNavigation(
      activeIconColor: colorPrimaryDark,
      inactiveIconColor: Colors.grey,
      textColor: colorPrimaryDark,
      circleSize: CircleSize.BIG,
      bigIconPadding: 10.0,
      tabs: [
        TabData(
            icon: Image(
              image: AssetImage("assets/ic_speaker.png"),
            ),
            title: "Feed"),
        TabData(
            icon: Image(
              image: AssetImage("assets/ic_profile.png"),
            ),
            title: "Profile")
      ],
      onTabChangedListener: (position) {
        setState(() {
          _currentIndex = position;
        });
      },
    );

See documentation to get information about all parameters

Screenshots #

[0.0.1] - 03.04.2019

  • ConvexBottomNavigation

[0.0.2] - 03.04.2019

  • homepage and file format

[0.0.3] - 03.04.2019

  • improved color settings

[0.0.4] - 03.04.2019

  • added documentation and screenshot

[1.0.0] - 13.05.2019

  • fixed formatting, improved description, added example, release version

[1.1.0] - 13.05.2019

  • fixed conflict with Future, customizable convex item

example/README.md

convex_bottom_navigation_example #

Demonstrates how to use the convex_bottom_navigation plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  convex_bottom_navigation: ^1.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:convex_bottom_navigation/convex_bottom_navigation.dart';
  
Version Uploaded Documentation Archive
1.1.0 May 13, 2019 Go to the documentation of convex_bottom_navigation 1.1.0 Download convex_bottom_navigation 1.1.0 archive
1.0.0 May 13, 2019 Go to the documentation of convex_bottom_navigation 1.0.0 Download convex_bottom_navigation 1.0.0 archive
0.0.4 Apr 3, 2019 Go to the documentation of convex_bottom_navigation 0.0.4 Download convex_bottom_navigation 0.0.4 archive
0.0.3 Apr 3, 2019 Go to the documentation of convex_bottom_navigation 0.0.3 Download convex_bottom_navigation 0.0.3 archive
0.0.2 Apr 3, 2019 Go to the documentation of convex_bottom_navigation 0.0.2 Download convex_bottom_navigation 0.0.2 archive
0.0.1 Apr 3, 2019 Go to the documentation of convex_bottom_navigation 0.0.1 Download convex_bottom_navigation 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
46
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
95
Overall:
Weighted score of the above. [more]
72
Learn more about scoring.

We analyzed this package on Jun 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
vector_math ^2.0.8 2.0.8
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
Dev dependencies
flutter_test