content_resolver 0.0.2
content_resolver: ^0.0.2 copied to clipboard

A plugin that help app to call ContentResolver on Android.

content_resolver #

The plugin is to resolve Android's content URI that is often used by Content providers.

Install #

Add this to your package's pubspec.yaml file and execute flutter pub get:

dependencies:
    content_resolver: ^0.0.2

Usage #

The following fragment is a use case with app_links to receive content:... URI content:

_appLinks = AppLinks(onAppLink: (uri) async {
  // If the data is some image, you can pass the data directly to Image.data or something.
  final Uint8List data = await ContentResolver.resolveContent(uri);
  ...
});
0
likes
90
pub points
53%
popularity

Publisher

espresso3389.jp

A plugin that help app to call ContentResolver on Android.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on content_resolver