content_provider 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 64

Flutter plugin for providing similar feature like content provider in android.

features:
1)Retrive data
2)insert data
3)update data
4)remove data

plugin methods to call :

1)retrive data:-
ContentProviderPlugin.getContentValue(String uri)
uri:-Simply pass uri of data you want to get
2)insert data:-
ContentProviderPlugin.insertContentValue(String uri, dynamic data)
uri:-Simply pass uri of where you want to insert data
data:-second parameter data is the data you want to insert
3)update data:-
ContentProviderPlugin.updateContentValue(String uri, dynamic data,{String where, List

Example:-https://github.com/deep-stl/content_provider/tree/master/example/lib

Permissions:-Permissions are not handle by plugin.users need to handle run time permission.

0.0.1 #

Provide basic crud operations for android content provider.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'widget/contact_widget.dart';

void main() => runApp(MyApp());

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  content_provider: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:content_provider/content_provider.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
45
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
64
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1
  • Flutter: 1.17.3

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:content_provider/content_provider.dart]

Package does not support Flutter platform macos

Because of import path [package:content_provider/content_provider.dart]

Package does not support Flutter platform web

Because of import path [package:content_provider/content_provider.dart]

Package does not support Flutter platform windows

Because of import path [package:content_provider/content_provider.dart]

Package not compatible with SDK dart

because of import path [content_provider]

Health issues and suggestions

Document public APIs. (-1 points)

7 out of 7 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/deep-stl/content_provider was unreachable.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-10 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.0
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test