cometchat_calls_uikit 4.3.3 copy "cometchat_calls_uikit: ^4.3.3" to clipboard
cometchat_calls_uikit: ^4.3.3 copied to clipboard

Flutter plugin featuring custom audio and video call widgets. Integrate seamlessly with Cometchat Chat UI Kit or use independently for streamlined development.

CometChat

CometChat Flutter Calls UIKit #

The CometChat Flutter Calls UI Kit provides a pre-built user interface kit that developers can use to quickly integrate a reliable & fully-featured chat experience into an existing or a new app.

Prerequisites #

  • Flutter >=3.10.5
  • Dart >=3.0.5
  • Android Studio 2022.2
  • Android 7.0, API 24 and above
  • Xcode 15
  • iOS 12.0

Getting Started #

To set up Flutter Calls UIKit and utilize CometChat for your chat and calls functionality, you'll need to follow these steps:

  • Register at the CometChat Dashboard to create an account.
  • After registering, log into your CometChat account and create a new app. Once created, CometChat will generate an Auth Key and App ID for you. Keep these credentials secure as you'll need them later.
  • Check the key concepts to understand the basic components of CometChat.
  • Refer to the Integration Steps Steps in our documentation to integrate the UI Kit into your Flutter app.

Help and Support #

For issues running the project or integrating with our UI Kits, consult our documentation or create a support ticket or seek real-time support via the CometChat Dashboard.

7
likes
140
pub points
85%
popularity

Publisher

verified publishercometchat.com

Flutter plugin featuring custom audio and video call widgets. Integrate seamlessly with Cometchat Chat UI Kit or use independently for streamlined development.

Homepage

Documentation

API reference

License

unknown (license)

Dependencies

cometchat_calls_sdk, cometchat_sdk, cometchat_uikit_shared, flutter, get, intl

More

Packages that depend on cometchat_calls_uikit