colorz 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 59

You're creating an app using Colors.green, or maybe even Colors.teal or Colors.pink? There are so many more inspiring colors you're missing out on!

Join the fun and say hello to Colorz.tardis, Colorz.driedToothpaste and Colorz.greenBanana! Make use of Colorz.cookieMonsterCottonCandy, Colorz.unoReverseCardBlue and Colorz.darkRavenclawBlue! Meet Colorz.arabicaMint, Colorz.pickleyCactus and Colorz.margesHair!

🎨 On colornames.org people from all over the word come together to name colors. This package makes the 9.000 most upvoted colors available in your Flutter app! That's the best 0.0536 % of all 16.7 million RGB colors!

⚠️ Disclaimer: The color names are chosen by the community and are not censored. Therefore, color names may include words considered offensive, vulgar or obscene.

❀️ Want to contribute? Visit colornames.org and provide some names or vote for colors to improve this package! If you find any issues or have ideas for improvements of this package, don't hesitate to create an issue in the GitHub repository.

πŸ“¦ Updates of this package: From time to time, I'll re-generate the Colorz and upload a major version upgrade to pub.dev (because there may be incompatibilities with previous versions). If you want to generate the Colorz yourself, go into the root directory of the colorz package and run dart generator/generator.dart.

πŸ€” Why only use the top 9.000 colors and not something round, like the top 10.000? pub.dev runs dartdoc with limited space: pub error

[1.0.0] - 2020-04-21 #

  • Package considered stable.

[0.1.0] - 2020-04-21 #

  • Updated readme.
  • Add generation date to generated file.

[0.0.6] - 2020-04-21 #

  • Add example.

[0.0.5] - 2020-04-21 #

  • Increase number of Colorz to 9.000.

[0.0.4] - 2020-04-21 #

  • Increase number of Colorz to 8.000.

[0.0.3] - 2020-04-21 #

  • Limit Colorz to 5.000 to make pub.dev happy.

[0.0.2] – 2020-04-16 #

  • Improve conversion of color names to Dart identifiers.
  • Limit Colorz to 10.000 colors to improve responsibility.

[0.0.1] – 2020-04-16 #

example/main.dart

import 'package:colorz/colorz.dart';
import 'package:flutter/material.dart';

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Column(
        children: [
          Container(height: 50, color: Colorz.aDisneyVillain),
          Container(height: 50, color: Colorz.almostMidnight),
          Container(height: 50, color: Colorz.raspberryFruityCream),
        ],
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  colorz: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:colorz/colorz.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
26
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
59
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • colorz that is a package requiring null.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

exitCode: -15 stdout: Exceeded timeout of 0:10:00.000000 Documenting colorz... Initialized dartdoc with 20 libraries in 64.8 seconds Generating docs for library colorz from package:colorz/colorz.dart... stderr: Exceeded timeout of 0:10:00.000000

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (dartx).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
archive ^2.0.13 2.0.13
console ^3.1.0 3.1.0
dartx ^0.3.0 0.3.0 0.4.2
flutter 0.0.0
http ^0.12.0+4 0.12.1
intl >=0.15.0 <1.0.0 0.16.1
mustache ^1.1.1 1.1.1
Transitive dependencies
args 1.6.0
characters 0.3.1 1.0.0
charcode 1.1.3
collection 1.14.12 1.14.13
convert 2.1.1
crypto 2.1.5
http_parser 3.1.4
meta 1.1.8 1.2.2
path 1.6.4 1.7.0
pedantic 1.9.0 1.9.2
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
time 1.3.0
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety