colorui 0.0.1

  • Readme
  • Changelog
  • Installing
  • new0

Colorui #

flutter 版本的实现

[0.0.1] #

  • 添加了图标资源

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  colorui: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:colorui/colorui.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis issues and suggestions

Make sure flutter format successfully runs on your package's source files.

Running flutter format failed with the following output:

Exception: dartfmt on lib/ failed with exit code 65
Could not format because the source could not be parsed:

line 19, column 2 of lib/basics/icons.dart: The name of a constructor must match the name of the enclosing class.
19 │     IconFont._();
   │     ^^^^^^^^
line 172, column 15 of lib/basics/icons.dart: Expected to find ';'.

Health issues and suggestions

Fix lib/basics/icons.dart. (-100 points)

Analysis of lib/basics/icons.dart failed with 602 errors, 4 hints, including:

line 19 col 2: The name of a constructor must match the name of the enclosing class.

line 20 col 15: IconData isn't a type.

line 20 col 37: Const variables must be initialized with a constant value.

line 21 col 15: IconData isn't a type.

line 21 col 32: Const variables must be initialized with a constant value.

Document public APIs. (-1 points)

300 out of 300 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field was unreachable.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and colorui.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies