colorful_log 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 55

ColorLog #

一款彩色的Log日志输出工具。

Screenshot

English | 中文 #

开始 #

1. 添加依赖 #

打开pubspec.yaml

# 远程依赖方式
dependencies:
  colorful_log: ^0.0.1

# 本地依赖方式
dependencies:
  colorful_log:
    path: PathOfProject

# git方式
dependencies:
  colorful_log:
    git:
      url: git://github.com/EngrZhou/ColorfulLog.git

2. 使用 #

///是否使用彩色log样式 true:使用 false:不使用
Log.setColorful(false);
///设置log输出级别
Log.setLogLevel(Log.warn);
///as android usual style
Log.V(tag, 'This is VERBOSE level colorful Log with custom tag.');

///as dart
Log.i(tag: tag, msg: 'This is INFO    level colorful Log with custom tag.');

///as dart
Log.d(msg: 'This is DEBUG   level colorful Log with none tag.');

LICENSE #

The 3-Clause BSD License

``## 0.0.1

  • First commit.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:colorful_log/colorful_log.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  final String tag = 'MyApp';

  @override
  void initState() {
    super.initState();
    _testLogPrinter();
  }

  _testLogPrinter() {
    Log.setLogLevel(Log.verbose);
    _logPrint(true);
    Log.setColorful(false);
    _logPrint(false);

    Log.setColorful(true);
    Log.i(msg: '>>>The following Log will only print warning levels<<<');

    Log.setLogLevel(Log.warn);
    _logPrint(true);
  }

  _logPrint(bool colorful) {
    ///as android usual
    Log.V(tag, 'This is VERBOSE level ${colorful?'colorful':'original'} Log with custom tag.');

    ///as dart
    Log.i(tag: tag, msg: 'This is INFO    level ${colorful?'colorful':'original'} Log with custom tag.');

    ///as dart
    Log.d(msg: '    This is DEBUG   level ${colorful?'colorful':'original'} Log with none tag.');

    ///as android usual
    Log.W(tag, 'This is WARN    level ${colorful?'colorful':'original'} Log with none tag.');

    ///as dart
    Log.e(msg: '    This is ERROR   level ${colorful?'colorful':'original'} Log with none tag.');
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: Column(
            mainAxisAlignment: MainAxisAlignment.center,
            crossAxisAlignment: CrossAxisAlignment.center,
            children: <Widget>[
              Text('Watch ur console.'),
              RaisedButton.icon(
                icon: Icon(Icons.info),
                label: Text('Click & Print'),
                onPressed: () {
                  _testLogPrinter();
                },
              ),
            ],
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  colorful_log: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:colorful_log/colorful_log.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
22
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
55
Learn more about scoring.

We analyzed this package on Mar 31, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health issues and suggestions

Document public APIs. (-1 points)

20 out of 20 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test