codenames_board 1.0.5

codenames_board #

A library for Dart developers.

Created from templates made available by Stagehand under a BSD-style license.

Usage #

A simple usage example:

import 'package:codenames_board/codenames_board.dart';

main() {
  var awesome = new Awesome();
}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

1.0.0 #

  • Initial version, created by Stagehand

example/codenames_board_example.dart

import 'dart:convert';
import 'dart:math';

import 'package:codenames_board/codenames_board.dart';

main() {
  Board baz =
      Board.filled(5, 5, List.generate(25, (ind) => ind.toString()), Random(1));
  print(jsonEncode(baz.toJson()));
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  codenames_board: ^1.0.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:codenames_board/codenames_board.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
69
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Aug 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:codenames_board/codenames_board.dart.

Health suggestions

Fix lib/src/codenames_board_base.dart. (-1.49 points)

Analysis of lib/src/codenames_board_base.dart reported 3 hints:

line 81 col 9: Don't type annotate initializing formals.

line 102 col 1: Prefer using /// for doc comments.

line 135 col 66: DO use curly braces for all flow control structures.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (json_annotation).

Homepage URL isn't helpful. (-10 points)

Update the homepage field from pubspec.yaml: link to a website about the package or use the source repository URL.

The package description is too short. (-8 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is getting outdated. (-3.29 points)

The package was last published 53 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
json_annotation ^1.0.0 1.2.0 3.0.0
Dev dependencies
build_runner any
json_serializable ^1.0.0
test ^1.0.0