cities 1.1.0 copy "cities: ^1.1.0" to clipboard
cities: ^1.1.0 copied to clipboard

A dataset containing 2.6 million cities that can be used by benchmarks or demos. Zero third party dependencies and completely self-contained.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add cities

With Flutter:

 $ flutter pub add cities

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  cities: ^1.1.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:cities/cities.dart';
6
likes
130
pub points
41%
popularity

Publisher

verified publishermodulovalue.com

A dataset containing 2.6 million cities that can be used by benchmarks or demos. Zero third party dependencies and completely self-contained.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

MIT (license)

More

Packages that depend on cities